CVE-2018-10657
CVE-2018-10657
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2^63 - 1 render rooms unusable, related to federation/federation_base.py and handlers/message.py, as exploited in the wild in April 2018.
CVSS 7.5 · High · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
matrix-synapse PyPI
- Affected ranges
- ECOSYSTEM: < 0.28.1
Update to 0.28.1
matrix-synapse Ubuntu:Pro:18.04:LTS
- Versions
- 0.19.2+dfsg-6
- 0.24.0+dfsg-1
- Affected ranges
- ECOSYSTEM: < 0.24.0+dfsg-1ubuntu0.1~esm1
Update to 0.24.0+dfsg-1ubuntu0.1~esm1