p PatchFirst

CVE-2018-1067

CVE-2018-1067

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to the injection of arbitrary HTTP headers, and also response splitting, due to insufficient sanitization and validation of user input before the input is used as part of an HTTP header value.

CVSS 5.4 · Medium · EPSS 1.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • undertow

    Versions
    • undertow 7.1.2.CR1: Affected
    • undertow 7.1.2.GA: Affected

    No fix published

  • undertow Debian:14

    Versions
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.19-1
    • 1.3.21-1
    • 1.3.23-1
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.18-1
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.21-2
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2
    • 1.4.23-3
    • 1.4.3-1
    • 1.4.4-1
    • 1.4.6-1
    • 1.4.7-1
    • 1.4.8-1
    Affected ranges
    • ECOSYSTEM: < 1.4.25-1

    Update to 1.4.25-1

  • undertow Ubuntu:Pro:16.04:LTS

    Versions
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.16-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • undertow Ubuntu:Pro:18.04:LTS

    Versions
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2build1
    • 1.4.23-3
    • 1.4.23-3ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • undertow Ubuntu:Pro:24.04:LTS

    Versions
    • 2.3.8-2
    • 2.3.8-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →