CVE-2018-1081
CVE-2018-1081
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions. Unauthenticated users can trigger custom messages to admin via paypal enrol script. Paypal IPN callback script should only send error emails to admin after request origin was verified, otherwise admin email can be spammed.
CVSS 5.3 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.10
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: ≥ 3.1, < 3.1.11
Update to 3.1.11
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.0-beta
- v3.2.0-rc1
- v3.2.0-rc2
- v3.2.0-rc3
- v3.2.0-rc4
- v3.2.0-rc5
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- Affected ranges
- ECOSYSTEM: ≥ 3.2, < 3.2.8
Update to 3.2.8
moodle/moodle Packagist
- Versions
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- Affected ranges
- ECOSYSTEM: ≥ 3.3, < 3.3.5
Update to 3.3.5
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- Affected ranges
- ECOSYSTEM: ≥ 3.4, < 3.4.2
Update to 3.4.2
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published