p PatchFirst

CVE-2018-1082

CVE-2018-1082

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.

CVSS 8.1 · High · EPSS 2.0% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • 3.4 to 3.4.1, 3.3 to 3.3.4: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.3.0
    • v3.3.0-beta
    • v3.3.0-rc1
    • v3.3.0-rc2
    • v3.3.0-rc3
    • v3.3.1
    • v3.3.2
    • v3.3.3
    • v3.3.4
    Affected ranges
    • ECOSYSTEM: ≥ 3.3, < 3.3.5

    Update to 3.3.5

  • moodle/moodle Packagist

    Versions
    • v3.4.0
    • v3.4.0-beta
    • v3.4.0-rc1
    • v3.4.0-rc2
    • v3.4.0-rc3
    • v3.4.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.4, < 3.4.2

    Update to 3.4.2

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →