p PatchFirst

CVE-2018-10851

CVE-2018-10851

This page contains facts from public vulnerability sources. Check the original advisory before updating.

PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.

CVSS 5.3 · Medium · EPSS 6.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • pdns

    Versions
    • 3.3.0 to 4.1.4, excluding 4.1.5 and 4.0.6: Affected

    No fix published

  • pdns-recursor

    Versions
    • 3.2 to 4.1.4, excluding 4.1.5 and 4.0.9: Affected

    No fix published

  • pdns Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.1.5-1

    Update to 4.1.5-1

  • pdns Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.5-1

    Update to 4.1.5-1

  • pdns Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1.5-1

    Update to 4.1.5-1

  • pdns-recursor Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.1.7-1

    Update to 4.1.7-1

  • pdns-recursor Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.7-1

    Update to 4.1.7-1

  • pdns-recursor Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.1.7-1

    Update to 4.1.7-1

  • pdns Ubuntu:Pro:16.04:LTS

    Versions
    • 3.4.5-1build2
    • 3.4.6-2
    • 3.4.6-3
    • 3.4.7-1
    • 3.4.7-2
    • 4.0.0~alpha1-1
    • 4.0.0~alpha2-2
    • 4.0.0~alpha2-3
    • 4.0.0~alpha2-3build1
    Affected ranges
    • ECOSYSTEM: < 4.0.0~alpha2-3ubuntu0.1~esm1

    Update to 4.0.0~alpha2-3ubuntu0.1~esm1

  • pdns-recursor Ubuntu:Pro:16.04:LTS

    Versions
    • 3.7.3-1
    • 4.0.0~alpha1-1
    • 4.0.0~alpha1-2
    • 4.0.0~alpha2-2
    • 4.0.0~alpha2-2ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 4.0.0~alpha2-2ubuntu0.1+esm1

    Update to 4.0.0~alpha2-2ubuntu0.1+esm1

  • pdns Ubuntu:Pro:18.04:LTS

    Versions
    • 4.0.4-2
    • 4.0.4-2build1
    • 4.0.5-1
    • 4.1.0-1
    • 4.1.0-2
    • 4.1.0-2build1
    • 4.1.1-1
    Affected ranges
    • ECOSYSTEM: < 4.1.1-1ubuntu0.1~esm1

    Update to 4.1.1-1ubuntu0.1~esm1

  • pdns-recursor Ubuntu:Pro:18.04:LTS

    Versions
    • 4.0.6-1
    • 4.0.6-1build1
    • 4.0.7-1
    • 4.1.1-1
    • 4.1.1-1build1
    • 4.1.1-2
    Affected ranges
    • ECOSYSTEM: < 4.1.1-2ubuntu0.1~esm1

    Update to 4.1.1-2ubuntu0.1~esm1

Original sources

Check your server →