CVE-2018-10852
CVE-2018-10852
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.
CVSS 3.8 · Low · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
sssd
- Versions
- SSSD 1.16.3: Affected
No fix published
sssd Debian:12
- Affected ranges
- ECOSYSTEM: < 1.16.3-1
Update to 1.16.3-1
sssd Debian:13
- Affected ranges
- ECOSYSTEM: < 1.16.3-1
Update to 1.16.3-1
sssd Ubuntu:Pro:16.04:LTS
- Versions
- 1.12.5-2
- 1.13.1-2
- 1.13.2-1
- 1.13.3-1
- 1.13.4-1
- 1.13.4-1ubuntu1
- 1.13.4-1ubuntu1.1
- 1.13.4-1ubuntu1.2
- 1.13.4-1ubuntu1.5
- 1.13.4-1ubuntu1.6
- 1.13.4-1ubuntu1.7
- 1.13.4-1ubuntu1.8
- 1.13.4-1ubuntu1.9
- 1.13.4-1ubuntu1.10
- 1.13.4-1ubuntu1.11
- 1.13.4-1ubuntu1.12
- 1.13.4-1ubuntu1.13
- 1.13.4-1ubuntu1.14
- 1.13.4-1ubuntu1.15
- 1.13.4-1ubuntu1.15+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
sssd Ubuntu:18.04:LTS
- Versions
- 1.15.3-2ubuntu1
- 1.15.3-3ubuntu1
- 1.16.0-5ubuntu1
- 1.16.0-5ubuntu2
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu1.1
- 1.16.1-1ubuntu1.2
- 1.16.1-1ubuntu1.3
- 1.16.1-1ubuntu1.4
- 1.16.1-1ubuntu1.5
- 1.16.1-1ubuntu1.6
- 1.16.1-1ubuntu1.7
- Affected ranges
- ECOSYSTEM: < 1.16.1-1ubuntu1.8
Update to 1.16.1-1ubuntu1.8