CVE-2018-10874
CVE-2018-10874
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under attacker's control, allowing to run arbitrary code as a result.
CVSS 7.8 · High · EPSS 0.5% · Fix available
- Published
- Updated
Affected products and versions
ansible
- Versions
- n/a: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 2.6.1+dfsg-1
Update to 2.6.1+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 2.6.1+dfsg-1
Update to 2.6.1+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 2.6.1+dfsg-1
Update to 2.6.1+dfsg-1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- Affected ranges
- ECOSYSTEM: < 2.4.6.0
Update to 2.4.6.0
ansible PyPI
- Versions
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- Affected ranges
- ECOSYSTEM: ≥ 2.5, < 2.5.6
Update to 2.5.6
ansible PyPI
- Versions
- 2.6.0
- Affected ranges
- ECOSYSTEM: ≥ 2.6, < 2.6.1
Update to 2.6.1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.1.4.0
- 2.1.5.0
- 2.1.6.0
- 2.2.0.0
- 2.2.1.0
- 2.2.2.0
- 2.2.3.0
- 2.3.0.0
- 2.3.1.0
- 2.3.2.0
- 2.3.3.0
- 2.4.0.0
- 2.4.1.0
- 2.4.2.0
- 2.4.3.0
- 2.4.4.0
- 2.4.5.0
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.6.0
- Affected ranges
- ECOSYSTEM: < 2.4.6.0 ∪ ≥ 2.5, < 2.5.6 ∪ ≥ 2.6, < 2.6.1
Update to 2.4.6.0; Update to 2.5.6; Update to 2.6.1
ansible Ubuntu:18.04:LTS
- Versions
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- Affected ranges
- ECOSYSTEM: < 2.5.1+dfsg-1ubuntu0.1
Update to 2.5.1+dfsg-1ubuntu0.1
Original sources
- https://access.redhat.com/errata/RHSA-2018:2166
- https://access.redhat.com/errata/RHSA-2018:2152
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10874
- https://access.redhat.com/errata/RHSA-2018:2150
- http://www.securitytracker.com/id/1041396
- https://access.redhat.com/errata/RHBA-2018:3788
- https://access.redhat.com/errata/RHSA-2019:0054
- https://access.redhat.com/errata/RHSA-2018:2151
- https://access.redhat.com/errata/RHSA-2018:2321
- https://access.redhat.com/errata/RHSA-2018:2585
- https://usn.ubuntu.com/4072-1/
- https://nvd.nist.gov/vuln/detail/CVE-2018-10874