p PatchFirst

CVE-2018-10889

CVE-2018-10889

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7. No option existed to omit logs from data privacy exports, which may contain details of other users who interacted with the requester.

CVSS 4.3 · Medium · EPSS 2.3% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • moodle

    Versions
    • moodle 3.5.1: Affected
    • moodle 3.4.4: Affected
    • moodle 3.3.7: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • 3.5
    • v3.5.0
    • v3.5.0-beta
    • v3.5.0-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5, < 3.5.1

    Update to 3.5.1

  • moodle/moodle Packagist

    Versions
    • 3.4.3
    • v3.4.3
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.3, < 3.4.4

    Update to 3.4.4

  • moodle/moodle Packagist

    Versions
    • v3.3.0
    • v3.3.0-beta
    • v3.3.0-rc1
    • v3.3.0-rc2
    • v3.3.0-rc3
    • v3.3.1
    • v3.3.2
    • v3.3.3
    • v3.3.4
    • v3.3.5
    • v3.3.6
    Affected ranges
    • ECOSYSTEM: ≥ 3.3, < 3.3.7

    Update to 3.3.7

  • moodle Ubuntu:Pro:16.04:LTS

    Versions
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • moodle Ubuntu:Pro:18.04:LTS

    Versions
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →