CVE-2018-10891
CVE-2018-10891
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.
CVSS 6.3 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- moodle 3.5.1: Affected
- moodle 3.4.4: Affected
- moodle 3.3.7: Affected
- moodle 3.1.13: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.5.0
- Affected ranges
- ECOSYSTEM: ≥ 3.5.0, < 3.5.1
Update to 3.5.1
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.1
- v3.4.2
- v3.4.3
- Affected ranges
- ECOSYSTEM: ≥ 3.4.0, < 3.4.4
Update to 3.4.4
moodle/moodle Packagist
- Versions
- v3.3.0
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- Affected ranges
- ECOSYSTEM: ≥ 3.3.0, < 3.3.7
Update to 3.3.7
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- v3.2.8
- v3.2.9
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 3.2.10
Update to 3.2.10
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.1
- v3.1.10
- v3.1.11
- v3.1.12
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: ≥ 3.1.0, < 3.1.13
Update to 3.1.13
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published