CVE-2018-10918
CVE-2018-10918
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A null pointer dereference flaw was found in the way samba checked database outputs from the LDB database layer. An authenticated attacker could use this flaw to crash a samba server in an Active Directory Domain Controller configuration. Samba versions before 4.7.9 and 4.8.4 are vulnerable.
CVSS 5.2 · Medium · EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- 4.7.9: Affected
- 4.8.4: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Ubuntu:18.04:LTS
- Versions
- 2:4.6.7+dfsg-1ubuntu3
- 2:4.7.1+dfsg-1ubuntu1
- 2:4.7.3+dfsg-1ubuntu1
- 2:4.7.4+dfsg-1ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu2
- Affected ranges
- ECOSYSTEM: < 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
Update to 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
Original sources
- https://www.samba.org/samba/security/CVE-2018-10918.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10918
- https://usn.ubuntu.com/3738-1/
- https://security.netapp.com/advisory/ntap-20180814-0001/
- http://www.securityfocus.com/bid/105083
- https://security.gentoo.org/glsa/202003-52
- https://nvd.nist.gov/vuln/detail/CVE-2018-10918