CVE-2018-10919
CVE-2018-10919
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The Samba Active Directory LDAP server was vulnerable to an information disclosure flaw because of missing access control checks. An authenticated attacker could use this flaw to extract confidential attribute values using LDAP search expressions. Samba versions before 4.6.16, 4.7.9 and 4.8.4 are vulnerable.
CVSS 4.3 · Medium · EPSS 2.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- 4.6.16: Affected
- 4.7.9: Affected
- 4.8.4: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.8.4+dfsg-1
Update to 2:4.8.4+dfsg-1
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- 2:4.3.8+dfsg-0ubuntu0.14.04.2
- 2:4.3.9+dfsg-0ubuntu0.14.04.1
- 2:4.3.9+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.1
- 2:4.3.11+dfsg-0ubuntu0.14.04.2
- 2:4.3.11+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.4
- 2:4.3.11+dfsg-0ubuntu0.14.04.6
- 2:4.3.11+dfsg-0ubuntu0.14.04.7
- 2:4.3.11+dfsg-0ubuntu0.14.04.8
- 2:4.3.11+dfsg-0ubuntu0.14.04.9
- 2:4.3.11+dfsg-0ubuntu0.14.04.10
- 2:4.3.11+dfsg-0ubuntu0.14.04.11
- 2:4.3.11+dfsg-0ubuntu0.14.04.12
- 2:4.3.11+dfsg-0ubuntu0.14.04.13
- 2:4.3.11+dfsg-0ubuntu0.14.04.14
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.14.04.16
Update to 2:4.3.11+dfsg-0ubuntu0.14.04.16
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- 2:4.3.8+dfsg-0ubuntu1
- 2:4.3.9+dfsg-0ubuntu0.16.04.1
- 2:4.3.9+dfsg-0ubuntu0.16.04.2
- 2:4.3.9+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.1
- 2:4.3.11+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.5
- 2:4.3.11+dfsg-0ubuntu0.16.04.6
- 2:4.3.11+dfsg-0ubuntu0.16.04.7
- 2:4.3.11+dfsg-0ubuntu0.16.04.8
- 2:4.3.11+dfsg-0ubuntu0.16.04.9
- 2:4.3.11+dfsg-0ubuntu0.16.04.10
- 2:4.3.11+dfsg-0ubuntu0.16.04.11
- 2:4.3.11+dfsg-0ubuntu0.16.04.12
- 2:4.3.11+dfsg-0ubuntu0.16.04.13
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.16.04.15
Update to 2:4.3.11+dfsg-0ubuntu0.16.04.15
samba Ubuntu:18.04:LTS
- Versions
- 2:4.6.7+dfsg-1ubuntu3
- 2:4.7.1+dfsg-1ubuntu1
- 2:4.7.3+dfsg-1ubuntu1
- 2:4.7.4+dfsg-1ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu2
- Affected ranges
- ECOSYSTEM: < 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
Update to 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
Original sources
- https://www.debian.org/security/2018/dsa-4271
- https://usn.ubuntu.com/3738-1/
- https://www.samba.org/samba/security/CVE-2018-10919.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10919
- https://security.netapp.com/advisory/ntap-20180814-0001/
- http://www.securityfocus.com/bid/105081
- https://security.gentoo.org/glsa/202003-52
- https://nvd.nist.gov/vuln/detail/CVE-2018-10919