p PatchFirst

CVE-2018-10933

CVE-2018-10933

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in libssh's server-side state machine before versions 0.7.6 and 0.8.4. A malicious client could create channels without first performing authentication, resulting in unauthorized access.

CVSS 9.1 · Critical · EPSS 91.8% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libssh

    Versions
    • 0.7.6: Affected
    • 0.8.4: Affected

    No fix published

  • libssh Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.8.4-1

    Update to 0.8.4-1

  • libssh Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.8.4-1

    Update to 0.8.4-1

  • libssh Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.8.4-1

    Update to 0.8.4-1

  • libssh Ubuntu:14.04:LTS

    Versions
    • 0.5.4-1
    • 0.6.1-0ubuntu2
    • 0.6.1-0ubuntu3
    • 0.6.1-0ubuntu3.1
    • 0.6.1-0ubuntu3.3
    Affected ranges
    • ECOSYSTEM: < 0.6.1-0ubuntu3.4

    Update to 0.6.1-0ubuntu3.4

  • libssh Ubuntu:16.04:LTS

    Versions
    • 0.6.3-3ubuntu3
    • 0.6.3-4.1
    • 0.6.3-4.2
    • 0.6.3-4.2ubuntu1
    • 0.6.3-4.3
    Affected ranges
    • ECOSYSTEM: < 0.6.3-4.3ubuntu0.1

    Update to 0.6.3-4.3ubuntu0.1

  • libssh Ubuntu:18.04:LTS

    Versions
    • 0.7.5-1
    • 0.8.0~20170825.94fa1e38-1
    • 0.8.0~20170825.94fa1e38-1build1
    Affected ranges
    • ECOSYSTEM: < 0.8.0~20170825.94fa1e38-1ubuntu0.1

    Update to 0.8.0~20170825.94fa1e38-1ubuntu0.1

Original sources

Check your server →