CVE-2018-10982
CVE-2018-10982
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Xen through 4.10.x allowing x86 HVM guest OS users to cause a denial of service (unexpectedly high interrupt number, array overrun, and hypervisor crash) or possibly gain hypervisor privileges by setting up an HPET timer to deliver interrupts in IO-APIC mode, aka vHPET interrupt injection.
CVSS 8.8 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
Update to 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
Update to 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
Update to 4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6
xen Ubuntu:16.04:LTS
- Versions
- 4.5.1-0ubuntu1
- 4.5.1-0ubuntu2
- 4.6.0-1ubuntu1
- 4.6.0-1ubuntu2
- 4.6.0-1ubuntu4
- 4.6.0-1ubuntu4.1
- 4.6.0-1ubuntu4.2
- 4.6.0-1ubuntu4.3
- 4.6.5-0ubuntu1
- 4.6.5-0ubuntu1.1
- 4.6.5-0ubuntu1.2
- 4.6.5-0ubuntu1.4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
xen Ubuntu:18.04:LTS
- Versions
- 4.9.0-0ubuntu3
- 4.9.0-0ubuntu4
- 4.9.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://security.gentoo.org/glsa/201810-06
- https://lists.debian.org/debian-lts-announce/2018/05/msg00015.html
- https://www.debian.org/security/2018/dsa-4201
- https://lists.debian.org/debian-lts-announce/2018/10/msg00009.html
- http://www.securityfocus.com/bid/104150
- http://openwall.com/lists/oss-security/2018/05/08/2
- https://xenbits.xen.org/xsa/advisory-261.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-10982