CVE-2018-1108
CVE-2018-1108
This page contains facts from public vulnerability sources. Check the original advisory before updating.
kernel drivers before version 4.17-rc1 are vulnerable to a weakness in the Linux kernel's implementation of random seed data. Programs, early in the boot sequence, could use the data allocated for the seed before it was sufficiently generated.
CVSS 5.9 · Medium · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
drivers
- Versions
- kernel 4.17-rc1: Affected
No fix published
linux Debian:12
- Affected ranges
- ECOSYSTEM: < 4.16.5-1
Update to 4.16.5-1
linux Debian:13
- Affected ranges
- ECOSYSTEM: < 4.16.5-1
Update to 4.16.5-1
linux Debian:14
- Affected ranges
- ECOSYSTEM: < 4.16.5-1
Update to 4.16.5-1
linux-azure Ubuntu:16.04:LTS
- Versions
- 4.11.0-1009.9
- 4.11.0-1011.11
- 4.11.0-1013.13
- 4.11.0-1014.14
- 4.11.0-1015.15
- 4.11.0-1016.16
- 4.13.0-1005.7
- 4.13.0-1006.8
- 4.13.0-1007.9
- 4.13.0-1009.12
- 4.13.0-1011.14
- 4.13.0-1012.15
- 4.13.0-1014.17
- 4.13.0-1016.19
- 4.13.0-1018.21
- 4.15.0-1013.13~16.04.2
- 4.15.0-1014.14~16.04.1
- 4.15.0-1018.18~16.04.1
- 4.15.0-1019.19~16.04.1
- 4.15.0-1021.21~16.04.1
- Affected ranges
- ECOSYSTEM: < 4.15.0-1022.22~16.04.1
Update to 4.15.0-1022.22~16.04.1
linux-gcp Ubuntu:16.04:LTS
- Versions
- 4.10.0-1004.4
- 4.10.0-1006.6
- 4.10.0-1007.7
- 4.10.0-1008.8
- 4.10.0-1009.9
- 4.13.0-1002.5
- 4.13.0-1006.9
- 4.13.0-1007.10
- 4.13.0-1008.11
- 4.13.0-1011.15
- 4.13.0-1012.16
- 4.13.0-1013.17
- 4.13.0-1015.19
- 4.13.0-1017.21
- 4.13.0-1019.23
- 4.15.0-1014.14~16.04.1
- 4.15.0-1015.15~16.04.1
- 4.15.0-1017.18~16.04.1
- Affected ranges
- ECOSYSTEM: < 4.15.0-1018.19~16.04.2
Update to 4.15.0-1018.19~16.04.2
linux-hwe Ubuntu:16.04:LTS
- Versions
- 4.8.0-36.36~16.04.1
- 4.8.0-39.42~16.04.1
- 4.8.0-41.44~16.04.1
- 4.8.0-42.45~16.04.1
- 4.8.0-44.47~16.04.1
- 4.8.0-45.48~16.04.1
- 4.8.0-46.49~16.04.1
- 4.8.0-49.52~16.04.1
- 4.8.0-51.54~16.04.1
- 4.8.0-52.55~16.04.1
- 4.8.0-53.56~16.04.1
- 4.8.0-54.57~16.04.1
- 4.8.0-56.61~16.04.1
- 4.8.0-58.63~16.04.1
- 4.10.0-27.30~16.04.2
- 4.10.0-28.32~16.04.2
- 4.10.0-30.34~16.04.1
- 4.10.0-32.36~16.04.1
- 4.10.0-33.37~16.04.1
- 4.10.0-35.39~16.04.1
- 4.10.0-37.41~16.04.1
- 4.10.0-38.42~16.04.1
- 4.10.0-40.44~16.04.1
- 4.10.0-42.46~16.04.1
- 4.13.0-26.29~16.04.2
- 4.13.0-31.34~16.04.1
- 4.13.0-32.35~16.04.1
- 4.13.0-36.40~16.04.1
- 4.13.0-37.42~16.04.1
- 4.13.0-38.43~16.04.1
- 4.13.0-39.44~16.04.1
- 4.13.0-41.46~16.04.1
- 4.13.0-43.48~16.04.1
- 4.13.0-45.50~16.04.1
- 4.15.0-24.26~16.04.1
- 4.15.0-29.31~16.04.1
- 4.15.0-30.32~16.04.1
- 4.15.0-32.35~16.04.1
- Affected ranges
- ECOSYSTEM: < 4.15.0-33.36~16.04.1
Update to 4.15.0-33.36~16.04.1
linux Ubuntu:18.04:LTS
- Versions
- 4.13.0-16.19
- 4.13.0-17.20
- 4.13.0-25.29
- 4.13.0-32.35
- 4.15.0-10.11
- 4.15.0-12.13
- 4.15.0-13.14
- 4.15.0-15.16
- 4.15.0-19.20
- 4.15.0-20.21
- 4.15.0-22.24
- 4.15.0-23.25
- 4.15.0-24.26
- 4.15.0-29.31
- 4.15.0-30.32
- 4.15.0-32.35
- Affected ranges
- ECOSYSTEM: < 4.15.0-33.36
Update to 4.15.0-33.36
linux-aws Ubuntu:18.04:LTS
- Versions
- 4.15.0-1001.1
- 4.15.0-1003.3
- 4.15.0-1005.5
- 4.15.0-1006.6
- 4.15.0-1007.7
- 4.15.0-1009.9
- 4.15.0-1010.10
- 4.15.0-1011.11
- 4.15.0-1016.16
- 4.15.0-1017.17
- 4.15.0-1019.19
- Affected ranges
- ECOSYSTEM: < 4.15.0-1020.20
Update to 4.15.0-1020.20
linux-azure Ubuntu:18.04:LTS
- Versions
- 4.15.0-1002.2
- 4.15.0-1003.3
- 4.15.0-1004.4
- 4.15.0-1008.8
- 4.15.0-1009.9
- 4.15.0-1012.12
- 4.15.0-1013.13
- 4.15.0-1014.14
- 4.15.0-1018.18
- 4.15.0-1019.19
- 4.15.0-1021.21
- Affected ranges
- ECOSYSTEM: < 4.15.0-1022.23
Update to 4.15.0-1022.23
linux-gcp Ubuntu:18.04:LTS
- Versions
- 4.15.0-1001.1
- 4.15.0-1003.3
- 4.15.0-1005.5
- 4.15.0-1006.6
- 4.15.0-1008.8
- 4.15.0-1009.9
- 4.15.0-1010.10
- 4.15.0-1014.14
- 4.15.0-1015.15
- 4.15.0-1017.18
- Affected ranges
- ECOSYSTEM: < 4.15.0-1018.19
Update to 4.15.0-1018.19
linux-kvm Ubuntu:18.04:LTS
- Versions
- 4.15.0-1002.2
- 4.15.0-1003.3
- 4.15.0-1004.4
- 4.15.0-1006.6
- 4.15.0-1008.8
- 4.15.0-1010.10
- 4.15.0-1011.11
- 4.15.0-1012.12
- 4.15.0-1016.16
- 4.15.0-1017.17
- 4.15.0-1019.19
- Affected ranges
- ECOSYSTEM: < 4.15.0-1020.20
Update to 4.15.0-1020.20
linux-oem Ubuntu:18.04:LTS
- Versions
- 4.15.0-1002.3
- 4.15.0-1004.5
- 4.15.0-1006.9
- 4.15.0-1008.11
- 4.15.0-1009.12
- 4.15.0-1012.15
- 4.15.0-1013.16
- 4.15.0-1015.18
- Affected ranges
- ECOSYSTEM: < 4.15.0-1017.20
Update to 4.15.0-1017.20
linux-raspi2 Ubuntu:18.04:LTS
- Versions
- 4.13.0-1005.5
- 4.13.0-1006.6
- 4.13.0-1008.8
- 4.15.0-1006.7
- 4.15.0-1009.10
- 4.15.0-1010.11
- 4.15.0-1011.12
- 4.15.0-1012.13
- 4.15.0-1013.14
- 4.15.0-1017.18
- 4.15.0-1018.19
- 4.15.0-1020.22
- Affected ranges
- ECOSYSTEM: < 4.15.0-1021.23
Update to 4.15.0-1021.23
Original sources
- https://usn.ubuntu.com/3752-2/
- https://usn.ubuntu.com/3752-3/
- https://usn.ubuntu.com/3718-2/
- http://www.securityfocus.com/bid/104055
- https://www.debian.org/security/2018/dsa-4188
- https://usn.ubuntu.com/3718-1/
- https://usn.ubuntu.com/3752-1/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1108
- https://lists.debian.org/debian-lts-announce/2022/07/msg00000.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1108