p PatchFirst

CVE-2018-11235

CVE-2018-11235

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16.x before 2.16.4, and 2.17.x before 2.17.1, remote code execution can occur. With a crafted .gitmodules file, a malicious project can execute an arbitrary script on a machine that runs "git clone --recurse-submodules" because submodule "names" are obtained from this file, and then appended to $GIT_DIR/modules, leading to directory traversal with "../" in a name. Finally, post-checkout hooks from a submodule are executed, bypassing the intended design in which hooks are not obtained from a remote server.

CVSS 7.8 · High · EPSS 48.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • git Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:2.17.1-1

    Update to 1:2.17.1-1

  • git Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:2.17.1-1

    Update to 1:2.17.1-1

  • git Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:2.17.1-1

    Update to 1:2.17.1-1

  • git Ubuntu:14.04:LTS

    Versions
    • 1:1.8.3.2-1
    • 1:1.8.4.2-1
    • 1:1.8.4.3-1
    • 1:1.8.4.4-1
    • 1:1.8.5-1
    • 1:1.8.5.1-1
    • 1:1.8.5.2-1
    • 1:1.8.5.2-2
    • 1:1.8.5.3-1
    • 1:1.9~rc1-1
    • 1:1.9.0-1
    • 1:1.9.1-1
    • 1:1.9.1-1ubuntu0.1
    • 1:1.9.1-1ubuntu0.2
    • 1:1.9.1-1ubuntu0.3
    • 1:1.9.1-1ubuntu0.4
    • 1:1.9.1-1ubuntu0.5
    • 1:1.9.1-1ubuntu0.6
    • 1:1.9.1-1ubuntu0.7
    Affected ranges
    • ECOSYSTEM: < 1:1.9.1-1ubuntu0.8

    Update to 1:1.9.1-1ubuntu0.8

  • git Ubuntu:16.04:LTS

    Versions
    • 1:2.5.0-1
    • 1:2.6.2-1
    • 1:2.6.3-1
    • 1:2.6.4-1
    • 1:2.7.0~rc3-1
    • 1:2.7.0-1
    • 1:2.7.3-0ubuntu1
    • 1:2.7.4-0ubuntu1
    • 1:2.7.4-0ubuntu1.1
    • 1:2.7.4-0ubuntu1.2
    • 1:2.7.4-0ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1:2.7.4-0ubuntu1.4

    Update to 1:2.7.4-0ubuntu1.4

  • git Ubuntu:18.04:LTS

    Versions
    • 1:2.14.1-1ubuntu4
    • 1:2.15.1-1ubuntu2
    • 1:2.17.0-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1:2.17.1-1ubuntu0.1

    Update to 1:2.17.1-1ubuntu0.1

Original sources

Check your server →