p PatchFirst

CVE-2018-1139

CVE-2018-1139

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the way samba before 4.7.9 and 4.8.4 allowed the use of weak NTLMv1 authentication even when NTLMv1 was explicitly disabled. A man-in-the-middle attacker could use this flaw to read the credential and other details passed between the samba server and client.

CVSS 5.4 · Medium · EPSS 3.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • samba

    Versions
    • before 4.7.9: Affected
    • before 4.8.4: Affected

    No fix published

  • samba Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.8.4+dfsg-1

    Update to 2:4.8.4+dfsg-1

  • samba Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.8.4+dfsg-1

    Update to 2:4.8.4+dfsg-1

  • samba Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.8.4+dfsg-1

    Update to 2:4.8.4+dfsg-1

  • samba Ubuntu:18.04:LTS

    Versions
    • 2:4.6.7+dfsg-1ubuntu3
    • 2:4.7.1+dfsg-1ubuntu1
    • 2:4.7.3+dfsg-1ubuntu1
    • 2:4.7.4+dfsg-1ubuntu1
    • 2:4.7.6+dfsg~ubuntu-0ubuntu1
    • 2:4.7.6+dfsg~ubuntu-0ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2:4.7.6+dfsg~ubuntu-0ubuntu2.2

    Update to 2:4.7.6+dfsg~ubuntu-0ubuntu2.2

Original sources

Check your server →