p PatchFirst

CVE-2018-11760

CVE-2018-11760

This page contains facts from public vulnerability sources. Check the original advisory before updating.

When using PySpark , it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application. This affects versions 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1.

CVSS 6.8 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • apache spark

    Versions
    • Apache Spark 1.x, 2.0.x, 2.1.x, 2.2.0 to 2.2.2, and 2.3.0 to 2.3.1: Affected

    No fix published

  • pyspark PyPI

    Versions
    • 2.3.0
    • 2.3.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.2

    Update to 2.3.2

  • pyspark PyPI

    Versions
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    Affected ranges
    • ECOSYSTEM: ≥ 1.0.2, < 2.2.3

    Update to 2.2.3

  • pyspark PyPI

    Versions
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.2 ∪ ≥ 1.0.2, < 2.2.3

    Update to 2.3.2; Update to 2.2.3

Original sources

Check your server →