CVE-2018-1279
CVE-2018-1279 · RabbitMQ cluster compromise due to deterministically generated cookie
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Pivotal RabbitMQ for PCF, all versions, uses a deterministically generated cookie that is shared between all machines when configured in a multi-tenant cluster. A remote attacker who can gain information about the network topology can guess this cookie and, if they have access to the right ports on any server in the MQ cluster can use this cookie to gain full control over the entire cluster.
CVSS 8.5 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
rabbitmq for pcf
- Versions
- ≥ 1, < all versions*: Affected (custom)
No fix published
rabbitmq-server Debian:12
- Affected ranges
- ECOSYSTEM: < 3.9.8-5
Update to 3.9.8-5
rabbitmq-server Debian:13
- Affected ranges
- ECOSYSTEM: < 3.9.8-5
Update to 3.9.8-5
rabbitmq-server Debian:14
- Affected ranges
- ECOSYSTEM: < 3.9.8-5
Update to 3.9.8-5
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versions
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versions
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- 3.8.3-0ubuntu0.3+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published