p PatchFirst

CVE-2018-14369

CVE-2018-14369

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Wireshark 2.6.0 to 2.6.1, 2.4.0 to 2.4.7, and 2.2.0 to 2.2.15, the HTTP2 dissector could crash. This was addressed in epan/dissectors/packet-http2.c by verifying that header data was found before proceeding to header decompression.

CVSS 7.5 · High · EPSS 3.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.6.2-1

    Update to 2.6.2-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.6.2-1

    Update to 2.6.2-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.6.2-1

    Update to 2.6.2-1

  • wireshark Ubuntu:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    • 1.10.6-1
    • 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu14.04.1

    Update to 2.6.3-1~ubuntu14.04.1

  • wireshark Ubuntu:16.04:LTS

    Versions
    • 1.12.7+g7fc8978-1
    • 1.12.8+g5b6e543-2
    • 2.0.1+g59ea380-3build1
    • 2.0.2+ga16e22e-1
    • 2.2.6+g32dac6a-2ubuntu0.16.04
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu16.04.1

    Update to 2.6.3-1~ubuntu16.04.1

  • wireshark Ubuntu:18.04:LTS

    Versions
    • 2.4.2-1
    • 2.4.3-1
    • 2.4.4-1
    • 2.4.5-1
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu18.04.1

    Update to 2.6.3-1~ubuntu18.04.1

Original sources

Check your server →