p PatchFirst

CVE-2018-14599

CVE-2018-14599

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in libX11 through 1.6.5. The function XListExtensions in ListExt.c is vulnerable to an off-by-one error caused by malicious server responses, leading to DoS or possibly unspecified other impact.

CVSS 9.8 · Critical · EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libx11 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:1.6.6-1

    Update to 2:1.6.6-1

  • libx11 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:1.6.6-1

    Update to 2:1.6.6-1

  • libx11 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:1.6.6-1

    Update to 2:1.6.6-1

  • libx11 Ubuntu:14.04:LTS

    Versions
    • 2:1.6.1-1ubuntu1
    • 2:1.6.1-1ubuntu2
    • 2:1.6.2-1ubuntu1
    • 2:1.6.2-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2:1.6.2-1ubuntu2.1

    Update to 2:1.6.2-1ubuntu2.1

  • libx11 Ubuntu:16.04:LTS

    Versions
    • 2:1.6.3-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2:1.6.3-1ubuntu2.1

    Update to 2:1.6.3-1ubuntu2.1

  • libx11 Ubuntu:18.04:LTS

    Versions
    • 2:1.6.4-3
    Affected ranges
    • ECOSYSTEM: < 2:1.6.4-3ubuntu0.1

    Update to 2:1.6.4-3ubuntu0.1

Original sources

Check your server →