CVE-2018-14626
CVE-2018-14626
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can lead to denial of service.
CVSS 5.3 · Medium · EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
pdns
- Versions
- 4.1.0 to 4.1.4 inclusive: Affected
No fix published
pdns-recursor
- Versions
- 4.0.0 to 4.1.4 inclusive: Affected
No fix published
pdns Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.5-1
Update to 4.1.5-1
pdns Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.5-1
Update to 4.1.5-1
pdns Debian:14
- Affected ranges
- ECOSYSTEM: < 4.1.5-1
Update to 4.1.5-1
pdns-recursor Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.7-1
Update to 4.1.7-1
pdns-recursor Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.7-1
Update to 4.1.7-1
pdns-recursor Debian:14
- Affected ranges
- ECOSYSTEM: < 4.1.7-1
Update to 4.1.7-1
pdns-recursor Ubuntu:Pro:16.04:LTS
- Versions
- 3.7.3-1
- 4.0.0~alpha1-1
- 4.0.0~alpha1-2
- 4.0.0~alpha2-2
- 4.0.0~alpha2-2ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 4.0.0~alpha2-2ubuntu0.1+esm1
Update to 4.0.0~alpha2-2ubuntu0.1+esm1
pdns Ubuntu:Pro:18.04:LTS
- Versions
- 4.0.4-2
- 4.0.4-2build1
- 4.0.5-1
- 4.1.0-1
- 4.1.0-2
- 4.1.0-2build1
- 4.1.1-1
- Affected ranges
- ECOSYSTEM: < 4.1.1-1ubuntu0.1~esm1
Update to 4.1.1-1ubuntu0.1~esm1
pdns-recursor Ubuntu:Pro:18.04:LTS
- Versions
- 4.0.6-1
- 4.0.6-1build1
- 4.0.7-1
- 4.1.1-1
- 4.1.1-1build1
- 4.1.1-2
- Affected ranges
- ECOSYSTEM: < 4.1.1-2ubuntu0.1~esm1
Update to 4.1.1-2ubuntu0.1~esm1