CVE-2018-14630
CVE-2018-14630
This page contains facts from public vulnerability sources. Check the original advisory before updating.
moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.
CVSS 8.8 · High · EPSS 4.6% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.5.2: Affected
- 3.4.5: Affected
- 3.3.8: Affected
- 3.1.14: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.1
- Affected ranges
- ECOSYSTEM: ≥ 3.5.0, < 3.5.2
Update to 3.5.2
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- Affected ranges
- ECOSYSTEM: ≥ 3.4.0, < 3.4.5
Update to 3.4.5
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- v3.2.7
- v3.2.8
- v3.2.9
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- v3.3.7
- Affected ranges
- ECOSYSTEM: ≥ 3.2.0, < 3.3.8
Update to 3.3.8
moodle/moodle Packagist
- Versions
- v2.3.10
- v2.3.11
- v2.3.4
- v2.3.5
- v2.3.6
- v2.3.7
- v2.3.8
- v2.3.9
- v2.4.0
- v2.4.0-rc1
- v2.4.1
- v2.4.10
- v2.4.11
- v2.4.2
- v2.4.3
- v2.4.4
- v2.4.5
- v2.4.6
- v2.4.7
- v2.4.8
- v2.4.9
- v2.5.0
- v2.5.0-beta
- v2.5.0-rc1
- v2.5.1
- v2.5.2
- v2.5.3
- v2.5.4
- v2.5.5
- v2.5.6
- v2.5.7
- v2.5.8
- v2.5.9
- v2.6.0
- v2.6.0-beta
- v2.6.0-rc1
- v2.6.1
- v2.6.10
- v2.6.11
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.6.7
- v2.6.8
- v2.6.9
- v2.7.0
- v2.7.0-beta
- v2.7.0-rc1
- v2.7.0-rc2
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.17
- v2.7.18
- v2.7.19
- v2.7.2
- v2.7.20
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- v2.8.0
- v2.8.0-beta
- v2.8.0-rc1
- v2.8.0-rc2
- v2.8.1
- v2.8.10
- v2.8.11
- v2.8.12
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v2.8.9
- v2.9.0
- v2.9.0-beta
- v2.9.0-rc1
- v2.9.0-rc2
- v2.9.1
- v2.9.2
- v2.9.3
- v2.9.4
- v2.9.5
- v2.9.6
- v2.9.7
- v2.9.8
- v2.9.9
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- v3.0.10
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.0.8
- v3.0.9
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.10
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: < 3.1.14
Update to 3.1.14
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/105354
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62880
- https://moodle.org/mod/forum/discuss.php?d=376023
- https://seclists.org/fulldisclosure/2018/Sep/28
- https://www.sec-consult.com/en/blog/advisories/remote-code-execution-php-unserialize-moodle-open-source-learning-platform-cve-2018-14630/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14630
- https://nvd.nist.gov/vuln/detail/CVE-2018-14630