CVE-2018-14631
CVE-2018-14631
This page contains facts from public vulnerability sources. Check the original advisory before updating.
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
CVSS 8.8 · High · EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
moodle
- Versions
- 3.5.2: Affected
- 3.4.5: Affected
- 3.3.8: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- v3.3.4
- v3.3.5
- v3.3.6
- v3.3.7
- Affected ranges
- ECOSYSTEM: ≥ 3.3, < 3.3.8
Update to 3.3.8
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- v3.4.1
- v3.4.2
- v3.4.3
- v3.4.4
- Affected ranges
- ECOSYSTEM: ≥ 3.4, < 3.4.5
Update to 3.4.5
moodle/moodle Packagist
- Versions
- v3.5.0
- v3.5.0-beta
- v3.5.0-rc1
- v3.5.1
- Affected ranges
- ECOSYSTEM: ≥ 3.5, < 3.5.2
Update to 3.5.2
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published