p PatchFirst

CVE-2018-14851

CVE-2018-14851

This page contains facts from public vulnerability sources. Check the original advisory before updating.

exif_process_IFD_in_MAKERNOTE in ext/exif/exif.c in PHP before 5.6.37, 7.0.x before 7.0.31, 7.1.x before 7.1.20, and 7.2.x before 7.2.8 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted JPEG file.

CVSS 5.5 · Medium · EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    • 5.5.9+dfsg-1ubuntu4.7
    • 5.5.9+dfsg-1ubuntu4.9
    • 5.5.9+dfsg-1ubuntu4.11
    • 5.5.9+dfsg-1ubuntu4.12
    • 5.5.9+dfsg-1ubuntu4.13
    • 5.5.9+dfsg-1ubuntu4.14
    • 5.5.9+dfsg-1ubuntu4.16
    • 5.5.9+dfsg-1ubuntu4.17
    • 5.5.9+dfsg-1ubuntu4.19
    • 5.5.9+dfsg-1ubuntu4.20
    • 5.5.9+dfsg-1ubuntu4.21
    • 5.5.9+dfsg-1ubuntu4.22
    • 5.5.9+dfsg-1ubuntu4.23
    • 5.5.9+dfsg-1ubuntu4.24
    • 5.5.9+dfsg-1ubuntu4.25
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.26

    Update to 5.5.9+dfsg-1ubuntu4.26

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    • 7.0.4-7ubuntu2.1
    • 7.0.8-0ubuntu0.16.04.1
    • 7.0.8-0ubuntu0.16.04.2
    • 7.0.8-0ubuntu0.16.04.3
    • 7.0.13-0ubuntu0.16.04.1
    • 7.0.15-0ubuntu0.16.04.1
    • 7.0.15-0ubuntu0.16.04.2
    • 7.0.15-0ubuntu0.16.04.4
    • 7.0.18-0ubuntu0.16.04.1
    • 7.0.22-0ubuntu0.16.04.1
    • 7.0.25-0ubuntu0.16.04.1
    • 7.0.28-0ubuntu0.16.04.1
    • 7.0.30-0ubuntu0.16.04.1
    Affected ranges
    • ECOSYSTEM: < 7.0.32-0ubuntu0.16.04.1

    Update to 7.0.32-0ubuntu0.16.04.1

  • php7.2 Ubuntu:18.04:LTS

    Versions
    • 7.2.1-1ubuntu2
    • 7.2.2-1ubuntu1
    • 7.2.2-1ubuntu2
    • 7.2.3-1ubuntu1
    • 7.2.5-0ubuntu0.18.04.1
    • 7.2.7-0ubuntu0.18.04.1
    • 7.2.7-0ubuntu0.18.04.2
    Affected ranges
    • ECOSYSTEM: < 7.2.10-0ubuntu0.18.04.1

    Update to 7.2.10-0ubuntu0.18.04.1

Original sources

Check your server →