CVE-2018-16510
CVE-2018-16510
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Artifex Ghostscript before 9.24. Incorrect exec stack handling in the "CS" and "SC" PDF primitives could be used by remote attackers able to supply crafted PDFs to crash the interpreter or possibly have unspecified other impact.
CVSS 7.8 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.25~dfsg-1
Update to 9.25~dfsg-1
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 9.22~dfsg+1-0ubuntu1.2
Update to 9.22~dfsg+1-0ubuntu1.2
Original sources
- http://openwall.com/lists/oss-security/2018/08/27/4
- https://security.gentoo.org/glsa/201811-12
- https://usn.ubuntu.com/3768-1/
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commit%3Bh=ea735ba37dc0fd5f5622d031830b9a559dec1cc9
- https://usn.ubuntu.com/3773-1/
- https://bugs.ghostscript.com/show_bug.cgi?id=699671
- https://nvd.nist.gov/vuln/detail/CVE-2018-16510