CVE-2018-16515
CVE-2018-16515
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.
CVSS 8.8 · High · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
matrix-synapse PyPI
- Affected ranges
- ECOSYSTEM: ≥ 0.33.3, < 0.33.3.1
Update to 0.33.3.1
matrix-synapse PyPI
- Affected ranges
- ECOSYSTEM: < 0.33.2.1
Update to 0.33.2.1
matrix-synapse PyPI
- Affected ranges
- ECOSYSTEM: < 0.33.2.1 ∪ ≥ 0.33.3, < 0.33.3.1
Update to 0.33.2.1; Update to 0.33.3.1
matrix-synapse Ubuntu:Pro:18.04:LTS
- Versions
- 0.19.2+dfsg-6
- 0.24.0+dfsg-1
- Affected ranges
- ECOSYSTEM: < 0.24.0+dfsg-1ubuntu0.1~esm1
Update to 0.24.0+dfsg-1ubuntu0.1~esm1
Original sources
- https://github.com/matrix-org/synapse/issues/3796#event-1833126269
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IRW7YR2H3ASUSYX4AO4KMY3FNVDNYW3P/
- https://matrix.org/blog/2018/09/06/critical-security-update-synapse-0-33-3-1/
- https://nvd.nist.gov/vuln/detail/CVE-2018-16515