CVE-2018-16831
CVE-2018-16831
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Smarty before 3.1.33-dev-4 allows attackers to bypass the trusted_dir protection mechanism via a file:./../ substring in an include statement.
CVSS 5.9 · Medium · EPSS 2.7% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
smarty3 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.1.33+20180830.1.3a78a21f+selfpack1-1
Update to 3.1.33+20180830.1.3a78a21f+selfpack1-1
smarty3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.33+20180830.1.3a78a21f+selfpack1-1
Update to 3.1.33+20180830.1.3a78a21f+selfpack1-1
smarty3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.33+20180830.1.3a78a21f+selfpack1-1
Update to 3.1.33+20180830.1.3a78a21f+selfpack1-1
smarty/smarty Packagist
- Versions
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- Affected ranges
- ECOSYSTEM: < 3.1.33
Update to 3.1.33
smarty3 Ubuntu:18.04:LTS
- Versions
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1