CVE-2018-16841
CVE-2018-16841
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Samba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.
CVSS 5.7 · Medium · EPSS 4.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- 4.7.12: Affected
- 4.8.7: Affected
- 4.9.3: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.9.2+dfsg-2
Update to 2:4.9.2+dfsg-2
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.9.2+dfsg-2
Update to 2:4.9.2+dfsg-2
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.9.2+dfsg-2
Update to 2:4.9.2+dfsg-2
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- 2:4.3.8+dfsg-0ubuntu0.14.04.2
- 2:4.3.9+dfsg-0ubuntu0.14.04.1
- 2:4.3.9+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.1
- 2:4.3.11+dfsg-0ubuntu0.14.04.2
- 2:4.3.11+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.4
- 2:4.3.11+dfsg-0ubuntu0.14.04.6
- 2:4.3.11+dfsg-0ubuntu0.14.04.7
- 2:4.3.11+dfsg-0ubuntu0.14.04.8
- 2:4.3.11+dfsg-0ubuntu0.14.04.9
- 2:4.3.11+dfsg-0ubuntu0.14.04.10
- 2:4.3.11+dfsg-0ubuntu0.14.04.11
- 2:4.3.11+dfsg-0ubuntu0.14.04.12
- 2:4.3.11+dfsg-0ubuntu0.14.04.13
- 2:4.3.11+dfsg-0ubuntu0.14.04.14
- 2:4.3.11+dfsg-0ubuntu0.14.04.16
- 2:4.3.11+dfsg-0ubuntu0.14.04.17
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.14.04.19
Update to 2:4.3.11+dfsg-0ubuntu0.14.04.19
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- 2:4.3.8+dfsg-0ubuntu1
- 2:4.3.9+dfsg-0ubuntu0.16.04.1
- 2:4.3.9+dfsg-0ubuntu0.16.04.2
- 2:4.3.9+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.1
- 2:4.3.11+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.5
- 2:4.3.11+dfsg-0ubuntu0.16.04.6
- 2:4.3.11+dfsg-0ubuntu0.16.04.7
- 2:4.3.11+dfsg-0ubuntu0.16.04.8
- 2:4.3.11+dfsg-0ubuntu0.16.04.9
- 2:4.3.11+dfsg-0ubuntu0.16.04.10
- 2:4.3.11+dfsg-0ubuntu0.16.04.11
- 2:4.3.11+dfsg-0ubuntu0.16.04.12
- 2:4.3.11+dfsg-0ubuntu0.16.04.13
- 2:4.3.11+dfsg-0ubuntu0.16.04.15
- 2:4.3.11+dfsg-0ubuntu0.16.04.16
- 2:4.3.11+dfsg-0ubuntu0.16.04.17
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.16.04.18
Update to 2:4.3.11+dfsg-0ubuntu0.16.04.18
samba Ubuntu:18.04:LTS
- Versions
- 2:4.6.7+dfsg-1ubuntu3
- 2:4.7.1+dfsg-1ubuntu1
- 2:4.7.3+dfsg-1ubuntu1
- 2:4.7.4+dfsg-1ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu1
- 2:4.7.6+dfsg~ubuntu-0ubuntu2
- 2:4.7.6+dfsg~ubuntu-0ubuntu2.2
- 2:4.7.6+dfsg~ubuntu-0ubuntu2.4
- Affected ranges
- ECOSYSTEM: < 2:4.7.6+dfsg~ubuntu-0ubuntu2.5
Update to 2:4.7.6+dfsg~ubuntu-0ubuntu2.5
Original sources
- http://www.securityfocus.com/bid/106023
- https://usn.ubuntu.com/3827-2/
- https://usn.ubuntu.com/3827-1/
- https://security.netapp.com/advisory/ntap-20181127-0001/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16841
- https://www.debian.org/security/2018/dsa-4345
- https://www.samba.org/samba/security/CVE-2018-16841.html
- https://security.gentoo.org/glsa/202003-52
- https://nvd.nist.gov/vuln/detail/CVE-2018-16841