p PatchFirst

CVE-2018-18478

CVE-2018-18478

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Persistent Cross-Site Scripting (XSS) issues in LibreNMS before 1.44 allow remote attackers to inject arbitrary web script or HTML via the dashboard_name parameter in the /ajax_form.php resource, related to html/includes/forms/add-dashboard.inc.php, html/includes/forms/delete-dashboard.inc.php, and html/includes/forms/edit-dashboard.inc.php.

CVSS 6.1 · Medium · EPSS 1.6% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • librenms/librenms Packagist

    Versions
    • 1.19
    • 1.20
    • 1.20.1
    • 1.21
    • 1.22
    • 1.22.01
    • 1.23
    • 1.24
    • 1.25
    • 1.26
    • 1.27
    • 1.28
    • 1.29
    • 1.30
    • 1.30.01
    • 1.31
    • 1.31.01
    • 1.31.02
    • 1.31.03
    • 1.32
    • 1.32.01
    • 1.33
    • 1.33.01
    • 1.34
    • 1.35
    • 1.36
    • 1.36.01
    • 1.37
    • 1.38
    • 1.39
    • 1.40
    • 1.41
    • 1.42
    • 1.42.01
    • 1.43
    Affected ranges
    • ECOSYSTEM: < 1.44

    Update to 1.44

Original sources

Check your server →