CVE-2018-19107
CVE-2018-19107
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Exiv2 0.26, Exiv2::IptcParser::decode in iptc.cpp (called from psdimage.cpp in the PSD image reader) may suffer from a denial of service (heap-based buffer over-read) caused by an integer overflow via a crafted PSD image file.
CVSS 6.5 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
exiv2 Debian:12
- Affected ranges
- ECOSYSTEM: < 0.27.2-6
Update to 0.27.2-6
exiv2 Debian:13
- Affected ranges
- ECOSYSTEM: < 0.27.2-6
Update to 0.27.2-6
exiv2 Debian:14
- Affected ranges
- ECOSYSTEM: < 0.27.2-6
Update to 0.27.2-6
exiv2 Ubuntu:16.04:LTS
- Versions
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- Affected ranges
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.4
Update to 0.25-2.1ubuntu16.04.4
exiv2 Ubuntu:18.04:LTS
- Versions
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- Affected ranges
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.3
Update to 0.25-3.1ubuntu0.18.04.3
Original sources
- https://lists.debian.org/debian-lts-announce/2019/02/msg00038.html
- https://github.com/Exiv2/exiv2/issues/427
- https://github.com/Exiv2/exiv2/pull/518
- https://usn.ubuntu.com/4056-1/
- https://access.redhat.com/errata/RHSA-2019:2101
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-19107