p PatchFirst

CVE-2018-19351

CVE-2018-19351

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Jupyter Notebook before 5.7.1 allows XSS via an untrusted notebook because nbconvert responses are considered to have the same origin as the notebook server. In other words, nbconvert endpoints can execute JavaScript with access to the server API. In notebook/nbconvert/handlers.py, NbconvertFileHandler and NbconvertPostHandler do not set a Content Security Policy to prevent this.

CVSS 6.1 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jupyter-notebook Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • jupyter-notebook Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • jupyter-notebook Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • notebook PyPI

    Versions
    • 0.0.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.2.0
    • 4.2.0b1
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    • 4.4.1
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.0rc3
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.2.2
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.5.0
    • 5.5.0rc1
    • 5.6.0
    • 5.6.0rc1
    • 5.7.0
    Affected ranges
    • ECOSYSTEM: < 5.7.1

    Update to 5.7.1

  • notebook PyPI

    Versions
    • 0.0.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.2.0
    • 4.2.0b1
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    • 4.4.1
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.0rc3
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.2.2
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.5.0
    • 5.5.0rc1
    • 5.6.0
    • 5.6.0rc1
    • 5.7.0
    Affected ranges
    • GIT: < 107a89fce5f413fb5728c1c5d2c7788e1fb17491
    • ECOSYSTEM: < 5.7.1

    Update to 5.7.1

  • jupyter-notebook Ubuntu:18.04:LTS

    Versions
    • 4.2.3-4
    • 5.1.0-2
    • 5.2.1-2
    • 5.2.2-1
    Affected ranges
    • ECOSYSTEM: < 5.2.2-1ubuntu0.1

    Update to 5.2.2-1ubuntu0.1

Original sources

Check your server →