CVE-2018-19352
CVE-2018-19352
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Jupyter Notebook before 5.7.2 allows XSS via a crafted directory name because notebook/static/tree/js/notebooklist.js handles certain URLs unsafely.
CVSS 6.1 · Medium · EPSS 1.3% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jupyter-notebook Debian:12
- Affected ranges
- ECOSYSTEM: < 5.7.4-1
Update to 5.7.4-1
jupyter-notebook Debian:13
- Affected ranges
- ECOSYSTEM: < 5.7.4-1
Update to 5.7.4-1
jupyter-notebook Debian:14
- Affected ranges
- ECOSYSTEM: < 5.7.4-1
Update to 5.7.4-1
notebook PyPI
- Versions
- 0.0.0
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.4
- 4.0.5
- 4.0.6
- 4.1.0
- 4.2.0
- 4.2.0b1
- 4.2.1
- 4.2.2
- 4.2.3
- 4.3.0
- 4.3.1
- 4.3.2
- 4.4.0
- 4.4.1
- 5.0.0
- 5.0.0b1
- 5.0.0b2
- 5.0.0rc1
- 5.0.0rc2
- 5.1.0
- 5.1.0rc1
- 5.1.0rc2
- 5.1.0rc3
- 5.2.0
- 5.2.0rc1
- 5.2.1
- 5.2.1rc1
- 5.2.2
- 5.3.0
- 5.3.0rc1
- 5.3.1
- 5.4.0
- 5.4.1
- 5.5.0
- 5.5.0rc1
- 5.6.0
- 5.6.0rc1
- 5.7.0
- 5.7.1
- Affected ranges
- ECOSYSTEM: < 5.7.2
Update to 5.7.2
notebook PyPI
- Versions
- 0.0.0
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.4
- 4.0.5
- 4.0.6
- 4.1.0
- 4.2.0
- 4.2.0b1
- 4.2.1
- 4.2.2
- 4.2.3
- 4.3.0
- 4.3.1
- 4.3.2
- 4.4.0
- 4.4.1
- 5.0.0
- 5.0.0b1
- 5.0.0b2
- 5.0.0rc1
- 5.0.0rc2
- 5.1.0
- 5.1.0rc1
- 5.1.0rc2
- 5.1.0rc3
- 5.2.0
- 5.2.0rc1
- 5.2.1
- 5.2.1rc1
- 5.2.2
- 5.3.0
- 5.3.0rc1
- 5.3.1
- 5.4.0
- 5.4.1
- 5.5.0
- 5.5.0rc1
- 5.6.0
- 5.6.0rc1
- 5.7.0
- 5.7.1
- Affected ranges
- GIT: < 288b73e1edbf527740e273fcc69b889460871648
- ECOSYSTEM: < 5.7.2
Update to 5.7.2