CVE-2018-19624
CVE-2018-19624
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Wireshark 2.6.0 to 2.6.4 and 2.4.0 to 2.4.10, the PVFS dissector could crash. This was addressed in epan/dissectors/packet-pvfs2.c by preventing a NULL pointer dereference.
CVSS 5.5 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 2.6.5-1
Update to 2.6.5-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 2.6.5-1
Update to 2.6.5-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 2.6.5-1
Update to 2.6.5-1
wireshark Ubuntu:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
- 2.6.3-1~ubuntu14.04.1
- 2.6.4-2~ubuntu14.04.1
- Affected ranges
- ECOSYSTEM: < 2.6.5-1~ubuntu14.04.1
Update to 2.6.5-1~ubuntu14.04.1
wireshark Ubuntu:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- 2.2.6+g32dac6a-2ubuntu0.16.04
- 2.6.3-1~ubuntu16.04.1
- 2.6.4-2~ubuntu16.04.0
- Affected ranges
- ECOSYSTEM: < 2.6.5-1~ubuntu16.04.0
Update to 2.6.5-1~ubuntu16.04.0
wireshark Ubuntu:18.04:LTS
- Versions
- 2.4.2-1
- 2.4.3-1
- 2.4.4-1
- 2.4.5-1
- 2.6.3-1~ubuntu18.04.1
- 2.6.4-2~ubuntu18.04.0
- Affected ranges
- ECOSYSTEM: < 2.6.5-1~ubuntu18.04.0
Update to 2.6.5-1~ubuntu18.04.0
Original sources
- https://www.wireshark.org/security/wnpa-sec-2018-56.html
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=15280
- https://lists.debian.org/debian-lts-announce/2019/01/msg00010.html
- http://www.securityfocus.com/bid/106051
- https://www.debian.org/security/2018/dsa-4359
- https://code.wireshark.org/review/gitweb?p=wireshark.git%3Ba=commit%3Bh=3e319db1107b08fc3be804b6d449143ec9aa0dec
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00027.html
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-19624