CVE-2018-19756
CVE-2018-19756
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There is a heap-based buffer over-read at stb_image.h (function: stbi__tga_load) in libsixel 1.8.2 that will cause a denial of service.
CVSS 5.5 · Medium · EPSS 0.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libsixel Debian:12
- Affected ranges
- ECOSYSTEM: < 1.8.2-2
Update to 1.8.2-2
libsixel Debian:13
- Affected ranges
- ECOSYSTEM: < 1.8.2-2
Update to 1.8.2-2
libsixel Debian:14
- Affected ranges
- ECOSYSTEM: < 1.8.2-2
Update to 1.8.2-2
libsixel Ubuntu:16.04:LTS
- Versions
- 1.4.2-1
- 1.5.2-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libsixel Ubuntu:18.04:LTS
- Versions
- 1.5.2-2
- 1.7.3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published