p PatchFirst

CVE-2018-19935

CVE-2018-19935

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ext/imap/php_imap.c in PHP 5.x and 7.x before 7.3.0 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty string in the message argument to the imap_mail function.

CVSS 7.5 · High · EPSS 6.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php-imap Ubuntu:14.04:LTS

    Versions
    • 5.4.6-0ubuntu3
    • 5.4.6-0ubuntu5
    Affected ranges
    • ECOSYSTEM: < 5.4.6-0ubuntu5.1

    Update to 5.4.6-0ubuntu5.1

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    • 7.0.4-7ubuntu2.1
    • 7.0.8-0ubuntu0.16.04.1
    • 7.0.8-0ubuntu0.16.04.2
    • 7.0.8-0ubuntu0.16.04.3
    • 7.0.13-0ubuntu0.16.04.1
    • 7.0.15-0ubuntu0.16.04.1
    • 7.0.15-0ubuntu0.16.04.2
    • 7.0.15-0ubuntu0.16.04.4
    • 7.0.18-0ubuntu0.16.04.1
    • 7.0.22-0ubuntu0.16.04.1
    • 7.0.25-0ubuntu0.16.04.1
    • 7.0.28-0ubuntu0.16.04.1
    • 7.0.30-0ubuntu0.16.04.1
    • 7.0.32-0ubuntu0.16.04.1
    Affected ranges
    • ECOSYSTEM: < 7.0.33-0ubuntu0.16.04.1

    Update to 7.0.33-0ubuntu0.16.04.1

  • php7.2 Ubuntu:18.04:LTS

    Versions
    • 7.2.1-1ubuntu2
    • 7.2.2-1ubuntu1
    • 7.2.2-1ubuntu2
    • 7.2.3-1ubuntu1
    • 7.2.5-0ubuntu0.18.04.1
    • 7.2.7-0ubuntu0.18.04.1
    • 7.2.7-0ubuntu0.18.04.2
    • 7.2.10-0ubuntu0.18.04.1
    Affected ranges
    • ECOSYSTEM: < 7.2.15-0ubuntu0.18.04.1

    Update to 7.2.15-0ubuntu0.18.04.1

Original sources

Check your server →