CVE-2018-20244
CVE-2018-20244
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.
CVSS 5.5 · Medium · EPSS 2.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- Apache Airflow <= 1.10.1: Affected
No fix published
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.10.1b1
- 1.10.1rc2
- 1.10.2b2
- 1.10.2rc1
- 1.10.2rc2
- 1.10.2rc3
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.10.2
Update to 1.10.2
Original sources
- https://lists.apache.org/thread.html/f656fddf9c49293b3ec450437c46709eb01a12d1645136b2f1b8573b%40%3Cdev.airflow.apache.org%3E
- https://lists.apache.org/thread.html/2de387213d45bc626d27554a1bde7b8c67d08720901f82a50b6f4231%40%3Cdev.airflow.apache.org%3E
- http://www.openwall.com/lists/oss-security/2019/04/10/6
- https://nvd.nist.gov/vuln/detail/CVE-2018-20244