CVE-2018-20245
CVE-2018-20245
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The LDAP auth backend (airflow.contrib.auth.backends.ldap_auth) prior to Apache Airflow 1.10.1 was misconfigured and contained improper checking of exceptions which disabled server certificate checking.
CVSS 8.7 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache airflow
- Versions
- Apache Airflow <= 1.10.0: Affected
No fix published
apache-airflow PyPI
- Versions
- 1.10.0
- 1.10.1b1
- 1.10.1rc2
- 1.8.1
- 1.8.2
- 1.8.2rc1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 1.10.1
Update to 1.10.1