p PatchFirst

CVE-2018-20505

CVE-2018-20505

This page contains facts from public vulnerability sources. Check the original advisory before updating.

SQLite 3.25.2, when queries are run on a table with a malformed PRIMARY KEY, allows remote attackers to cause a denial of service (application crash) by leveraging the ability to run arbitrary SQL statements (such as in certain WebSQL use cases).

CVSS 7.5 · High · EPSS 6.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • sqlite3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.25.3-1

    Update to 3.25.3-1

  • sqlite3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.25.3-1

    Update to 3.25.3-1

  • sqlite3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.25.3-1

    Update to 3.25.3-1

  • sqlite3 Ubuntu:18.04:LTS

    Versions
    • 3.19.3-3
    • 3.20.1-2
    • 3.21.0-1
    • 3.22.0-1
    Affected ranges
    • ECOSYSTEM: < 3.22.0-1ubuntu0.1

    Update to 3.22.0-1ubuntu0.1

Original sources

Check your server →