p PatchFirst

CVE-2018-20717

CVE-2018-20717

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.

CVSS 8.8 · High · EPSS 2.7% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • prestashop/prestashop Packagist

    Versions
    • 1.7.0.0
    • 1.7.0.0-beta.1.0
    • 1.7.0.0-beta.2.0
    • 1.7.0.0-beta.3.0
    • 1.7.0.0-beta.4.0
    • 1.7.0.0-rc.0.0
    • 1.7.0.0-rc.1.0
    • 1.7.0.0-rc.2.0
    • 1.7.0.1
    • 1.7.0.2
    • 1.7.0.3
    • 1.7.0.4
    • 1.7.0.5
    • 1.7.0.6
    • 1.7.1.0
    • 1.7.1.1
    • 1.7.1.2
    • 1.7.2.0
    • 1.7.2.0-rc.1.0
    • 1.7.2.1
    • 1.7.2.2
    • 1.7.2.3
    • 1.7.2.4
    Affected ranges
    • ECOSYSTEM: < 1.7.2.5

    Update to 1.7.2.5

Original sources

Check your server →