CVE-2018-20802
CVE-2018-20802 · Post-auth queries on compound index may crash mongod
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries with compound indexes affecting QueryPlanner. This issue affects MongoDB Server v3.6 versions prior to 3.6.9 and MongoDB Server v4.0 versions prior to 4.0.3.
CVSS 6.5 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 3.6, < 3.6.9: Affected (custom)
- ≥ 4.0, < 4.0.3: Affected (custom)
Update to 3.6.9; Update to 4.0.3
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- Affected ranges
- ECOSYSTEM: < 1:3.6.3-0ubuntu1.4+esm1
Update to 1:3.6.3-0ubuntu1.4+esm1