CVE-2018-20804
CVE-2018-20804 · Invariant failure in applyOps
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A user authorized to perform database queries may trigger denial of service by issuing specially crafted applyOps invocations. This issue affects MongoDB Server v4.0 versions prior to 4.0.10 and MongoDB Server v3.6 versions prior to 3.6.13.
CVSS 6.5 · Medium · EPSS 1.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 3.6, < 3.6.13: Affected (custom)
- ≥ 4.0, < 4.0.10: Affected (custom)
Update to 3.6.13; Update to 4.0.10
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- 1:3.6.3-0ubuntu1.4+esm1
- 1:3.6.3-0ubuntu1.4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published