p PatchFirst

CVE-2018-21030

CVE-2018-21030

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Jupyter Notebook before 5.5.0 does not use a CSP header to treat served files as belonging to a separate origin. Thus, for example, an XSS payload can be placed in an SVG document.

CVSS 6.9 · Medium · EPSS 1.4% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jupyter-notebook Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • jupyter-notebook Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • jupyter-notebook Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.7.4-1

    Update to 5.7.4-1

  • notebook PyPI

    Versions
    • 0.0.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.2.0
    • 4.2.0b1
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    • 4.4.1
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.0rc3
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.2.2
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.4.0
    • 5.4.1
    Affected ranges
    • ECOSYSTEM: < 5.5.0rc1

    Update to 5.5.0rc1

  • notebook PyPI

    Versions
    • 0.0.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.2.0
    • 4.2.0b1
    • 4.2.1
    • 4.2.2
    • 4.2.3
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.4.0
    • 4.4.1
    • 5.0.0
    • 5.0.0b1
    • 5.0.0b2
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.0rc3
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.2.2
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.4.0
    • 5.4.1
    • 5.5.0rc1
    Affected ranges
    • ECOSYSTEM: < 5.5.0

    Update to 5.5.0

  • jupyter-notebook Ubuntu:18.04:LTS

    Versions
    • 4.2.3-4
    • 5.1.0-2
    • 5.2.1-2
    • 5.2.2-1
    Affected ranges
    • ECOSYSTEM: < 5.2.2-1ubuntu0.1

    Update to 5.2.2-1ubuntu0.1

Original sources

Check your server →