CVE-2018-21233
CVE-2018-21233
This page contains facts from public vulnerability sources. Check the original advisory before updating.
TensorFlow before 1.7.0 has an integer overflow that causes an out-of-bounds read, possibly causing disclosure of the contents of process memory. This occurs in the DecodeBmp feature of the BMP decoder in core/kernels/decode_bmp_op.cc.
CVSS 7.1 · High · EPSS 0.6% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- Affected ranges
- ECOSYSTEM: < 1.7.0
Update to 1.7.0
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- Affected ranges
- ECOSYSTEM: < 1.7.0
Update to 1.7.0
tensorflow PyPI
- Versions
- 0.12.0
- 0.12.0rc0
- 0.12.0rc1
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.2.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.3.0
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.4.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.1
- 1.5.0
- 1.5.0rc0
- 1.5.0rc1
- 1.5.1
- 1.6.0
- 1.6.0rc0
- 1.6.0rc1
- 1.7.0rc0
- 1.7.0rc1
- Affected ranges
- GIT: < 49f73c55d56edffebde4bca4a407ad69c1cae433
- ECOSYSTEM: < 1.7.0
Update to 1.7.0
tensorflow-cpu PyPI
- Affected ranges
- GIT: < 49f73c55d56edffebde4bca4a407ad69c1cae433
- ECOSYSTEM: < 1.7.0
Update to 1.7.0
tensorflow-gpu PyPI
- Versions
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 0.5.0
- Affected ranges
- GIT: < 49f73c55d56edffebde4bca4a407ad69c1cae433
- ECOSYSTEM: < 1.7.0
Update to 1.7.0