p PatchFirst

CVE-2018-25004

CVE-2018-25004 · Invariant failure when explaining a find with a UUID

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A user authorized to performing a specific type of query may trigger a denial of service by issuing a generic explain command on a find query. This issue affects MongoDB Server v4.0 versions prior to 4.0.6 and MongoDB Server v3.6 versions prior to 3.6.11.

CVSS 4.9 · Medium · EPSS 1.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongodb server

    Versions
    • ≥ 3.6, < 3.6.11: Affected (custom)
    • ≥ 4.0, < 4.0.6: Affected (custom)

    Update to 3.6.11; Update to 4.0.6

  • mongodb Ubuntu:Pro:14.04:LTS

    Versions
    • 1:2.4.6-0ubuntu5
    • 1:2.4.6-0ubuntu6
    • 1:2.4.8-1ubuntu1
    • 1:2.4.8-2
    • 1:2.4.9-1
    • 1:2.4.9-1ubuntu1
    • 1:2.4.9-1ubuntu2
    • 1:2.4.9-1ubuntu2+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:16.04:LTS

    Versions
    • 1:2.6.10-0ubuntu1
    • 1:2.6.10-0ubuntu1+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:18.04:LTS

    Versions
    • 1:3.4.7-1
    • 1:3.4.7-1ubuntu1
    • 1:3.4.7-1ubuntu2
    • 1:3.4.7-1ubuntu4
    • 1:3.4.14-3ubuntu1
    • 1:3.4.14-3ubuntu2
    • 1:3.6.3-0ubuntu1
    • 1:3.6.3-0ubuntu1.1
    • 1:3.6.3-0ubuntu1.3
    • 1:3.6.3-0ubuntu1.4
    • 1:3.6.3-0ubuntu1.4+esm1
    • 1:3.6.3-0ubuntu1.4+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mongodb Ubuntu:Pro:20.04:LTS

    Versions
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
    • 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →