CVE-2018-25047
CVE-2018-25047
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
CVSS 5.4 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
smarty3 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.1.47-1
Update to 3.1.47-1
smarty3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.47-1
Update to 3.1.47-1
smarty3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.47-1
Update to 3.1.47-1
smarty4 Debian:12
- Affected ranges
- ECOSYSTEM: < 4.2.1-1
Update to 4.2.1-1
smarty4 Debian:13
- Affected ranges
- ECOSYSTEM: < 4.2.1-1
Update to 4.2.1-1
smarty4 Debian:14
- Affected ranges
- ECOSYSTEM: < 4.2.1-1
Update to 4.2.1-1
smarty/smarty Packagist
- Versions
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- v3.1.42
- v3.1.43
- v3.1.44
- v3.1.45
- v3.1.46
- Affected ranges
- ECOSYSTEM: < 3.1.47
Update to 3.1.47
smarty/smarty Packagist
- Versions
- v4.0.0
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.1.0
- v4.1.1
- v4.2.0
- Affected ranges
- ECOSYSTEM: ≥ 4.0.0, < 4.2.1
Update to 4.2.1
smarty3 Ubuntu:Pro:16.04:LTS
- Versions
- 3.1.21-1
- 3.1.21-1ubuntu1
- 3.1.21-1ubuntu1+esm1
- 3.1.21-1ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
smarty3 Ubuntu:Pro:18.04:LTS
- Versions
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
smarty3 Ubuntu:20.04:LTS
- Versions
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- Affected ranges
- ECOSYSTEM: < 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
Update to 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
smarty3 Ubuntu:22.04:LTS
- Versions
- 3.1.39-2
- 3.1.39-2ubuntu1
- 3.1.39-2ubuntu1.22.04.1
- Affected ranges
- ECOSYSTEM: < 3.1.39-2ubuntu1.22.04.2
Update to 3.1.39-2ubuntu1.22.04.2
smarty3 Ubuntu:24.04:LTS
- Versions
- 3.1.48-1
- Affected ranges
- ECOSYSTEM: < 3.1.48-1ubuntu0.24.04.1
Update to 3.1.48-1ubuntu0.24.04.1
smarty3 Ubuntu:25.10
- Versions
- 3.1.48-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
smarty3 Ubuntu:26.10
- Versions
- 3.1.48-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
smarty3 Ubuntu:26.04:LTS
- Versions
- 3.1.48-2
- 3.1.48-2build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/smarty-php/smarty/issues/454
- https://github.com/smarty-php/smarty/releases/tag/v4.2.1
- https://github.com/smarty-php/smarty/releases/tag/v3.1.47
- https://bugs.gentoo.org/870100
- https://security.gentoo.org/glsa/202209-09
- https://lists.debian.org/debian-lts-announce/2023/01/msg00002.html
- https://lists.debian.org/debian-lts-announce/2024/11/msg00013.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-25047