CVE-2018-2583
CVE-2018-2583
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Stored Procedure). Supported versions that are affected are 5.6.38 and prior and 5.7.20 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. While the vulnerability is in MySQL Server, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.8 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H).
CVSS 6.8 · Medium · EPSS 3.0% · Fix available
- Published
- Updated
Affected products and versions
mysql
- Versions
- 5.6.38 and prior: Affected
- 5.7.20 and prior: Affected
No fix published
mysql-5.7 Ubuntu:16.04:LTS
- Versions
- 5.7.11-0ubuntu4
- 5.7.11-0ubuntu5
- 5.7.11-0ubuntu6
- 5.7.12-0ubuntu1
- 5.7.12-0ubuntu1.1
- 5.7.13-0ubuntu0.16.04.2
- 5.7.15-0ubuntu0.16.04.1
- 5.7.16-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.2
- 5.7.18-0ubuntu0.16.04.1
- 5.7.19-0ubuntu0.16.04.1
- 5.7.20-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 5.7.21-0ubuntu0.16.04.1
Update to 5.7.21-0ubuntu0.16.04.1
percona-server-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.22-rel71.0-0ubuntu2
- 5.6.22-rel71.0-0ubuntu4
- 5.6.22-rel71.0-0ubuntu4.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.21-25.8-0ubuntu2
- 5.6.21-25.8-0ubuntu3
- 5.6.21-25.8-0ubuntu3.1
- 5.6.21-25.8-0ubuntu3.2
- 5.6.34-26.19-0ubuntu0.16.04.1
- 5.6.34-26.19-0ubuntu0.16.04.2
- 5.6.37-26.21-0ubuntu0.16.04.1
- 5.6.37-26.21-0ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mysql-5.7 Ubuntu:18.04:LTS
- Versions
- 5.7.19-0ubuntu1
- 5.7.20-0ubuntu0.17.10.1
- 5.7.20-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 5.7.21-1ubuntu1
Update to 5.7.21-1ubuntu1
Original sources
- https://access.redhat.com/errata/RHSA-2018:0587
- http://www.securityfocus.com/bid/102708
- https://usn.ubuntu.com/3537-1/
- https://access.redhat.com/errata/RHSA-2018:0586
- http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
- https://security.netapp.com/advisory/ntap-20180117-0002/
- http://www.securitytracker.com/id/1040216
- https://nvd.nist.gov/vuln/detail/CVE-2018-2583