CVE-2018-2755
CVE-2018-2755
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Replication). Supported versions that are affected are 5.5.59 and prior, 5.6.39 and prior and 5.7.21 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with logon to the infrastructure where MySQL Server executes to compromise MySQL Server. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in MySQL Server, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of MySQL Server. CVSS 3.0 Base Score 7.7 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).
CVSS 7.7 · High · EPSS 0.8% · Fix available
- Published
- Updated
Affected products and versions
mysql
- Versions
- 5.5.59 and prior: Affected
- 5.6.39 and prior: Affected
- 5.7.21 and prior: Affected
No fix published
mariadb-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-1ubuntu1
- 5.5.35-1ubuntu1
- 5.5.36-1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.39-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.2
- 5.5.41-1ubuntu0.14.04.1
- 5.5.43-1ubuntu0.14.04.2
- 5.5.44-1ubuntu0.14.04.1
- 5.5.46-1ubuntu0.14.04.2
- 5.5.47-1ubuntu0.14.04.1
- 5.5.49-1ubuntu0.14.04.1
- 5.5.52-1ubuntu0.14.04.1
- 5.5.53-1ubuntu0.14.04.1
- 5.5.54-1ubuntu0.14.04.1
- 5.5.56-1ubuntu0.14.04.1
- 5.5.57-1ubuntu0.14.04.1
- 5.5.58-1ubuntu0.14.04.1
- 5.5.59-1ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.61-1ubuntu0.14.04.1
Update to 5.5.61-1ubuntu0.14.04.1
mysql-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-0ubuntu7
- 5.5.34-0ubuntu1
- 5.5.34-0ubuntu2
- 5.5.35-0ubuntu1
- 5.5.35+dfsg-1ubuntu1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.38-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.1
- 5.5.43-0ubuntu0.14.04.1
- 5.5.44-0ubuntu0.14.04.1
- 5.5.46-0ubuntu0.14.04.2
- 5.5.47-0ubuntu0.14.04.1
- 5.5.49-0ubuntu0.14.04.1
- 5.5.50-0ubuntu0.14.04.1
- 5.5.52-0ubuntu0.14.04.1
- 5.5.53-0ubuntu0.14.04.1
- 5.5.54-0ubuntu0.14.04.1
- 5.5.55-0ubuntu0.14.04.1
- 5.5.57-0ubuntu0.14.04.1
- 5.5.58-0ubuntu0.14.04.1
- 5.5.59-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.60-0ubuntu0.14.04.1
Update to 5.5.60-0ubuntu0.14.04.1
mariadb-10.0 Ubuntu:16.04:LTS
- Versions
- 10.0.20-0ubuntu0.15.04.1
- 10.0.22-0ubuntu1
- 10.0.23-1
- 10.0.23-2
- 10.0.24-7
- 10.0.25-0ubuntu0.16.04.1
- 10.0.27-0ubuntu0.16.04.1
- 10.0.28-0ubuntu0.16.04.1
- 10.0.29-0ubuntu0.16.04.1
- 10.0.31-0ubuntu0.16.04.2
- 10.0.33-0ubuntu0.16.04.1
- 10.0.34-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 10.0.36-0ubuntu0.16.04.1
Update to 10.0.36-0ubuntu0.16.04.1
mysql-5.7 Ubuntu:16.04:LTS
- Versions
- 5.7.11-0ubuntu4
- 5.7.11-0ubuntu5
- 5.7.11-0ubuntu6
- 5.7.12-0ubuntu1
- 5.7.12-0ubuntu1.1
- 5.7.13-0ubuntu0.16.04.2
- 5.7.15-0ubuntu0.16.04.1
- 5.7.16-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.2
- 5.7.18-0ubuntu0.16.04.1
- 5.7.19-0ubuntu0.16.04.1
- 5.7.20-0ubuntu0.16.04.1
- 5.7.21-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 5.7.22-0ubuntu0.16.04.1
Update to 5.7.22-0ubuntu0.16.04.1
percona-server-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.22-rel71.0-0ubuntu2
- 5.6.22-rel71.0-0ubuntu4
- 5.6.22-rel71.0-0ubuntu4.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.21-25.8-0ubuntu2
- 5.6.21-25.8-0ubuntu3
- 5.6.21-25.8-0ubuntu3.1
- 5.6.21-25.8-0ubuntu3.2
- 5.6.34-26.19-0ubuntu0.16.04.1
- 5.6.34-26.19-0ubuntu0.16.04.2
- 5.6.37-26.21-0ubuntu0.16.04.1
- 5.6.37-26.21-0ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mysql-5.7 Ubuntu:18.04:LTS
- Versions
- 5.7.19-0ubuntu1
- 5.7.20-0ubuntu0.17.10.1
- 5.7.20-1ubuntu1
- 5.7.21-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 5.7.22-0ubuntu18.04.1
Update to 5.7.22-0ubuntu18.04.1
Original sources
- https://www.debian.org/security/2018/dsa-4341
- http://www.securitytracker.com/id/1040698
- https://access.redhat.com/errata/RHSA-2018:1254
- https://security.netapp.com/advisory/ntap-20180419-0002/
- https://access.redhat.com/errata/RHSA-2018:2729
- https://www.debian.org/security/2018/dsa-4176
- https://lists.debian.org/debian-lts-announce/2018/06/msg00015.html
- http://www.securityfocus.com/bid/103807
- https://lists.debian.org/debian-lts-announce/2018/04/msg00020.html
- https://access.redhat.com/errata/RHSA-2018:3655
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- https://access.redhat.com/errata/RHSA-2018:2439
- https://usn.ubuntu.com/3629-1/
- https://usn.ubuntu.com/3629-2/
- https://usn.ubuntu.com/3629-3/
- https://access.redhat.com/errata/RHSA-2019:1258
- https://security.gentoo.org/glsa/201908-24
- https://nvd.nist.gov/vuln/detail/CVE-2018-2755