CVE-2018-3183
CVE-2018-3183
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE (subcomponent: Scripting). Supported versions that are affected are Java SE: 8u182 and 11; Java SE Embedded: 8u181; JRockit: R28.3.19. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, JRockit. While the vulnerability is in Java SE, Java SE Embedded, JRockit, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded, JRockit. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g. code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g. through a web service which supplies data to the APIs. CVSS 3.0 Base Score 9.0 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H).
CVSS 9.0 · Critical · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system · applications
Affected products and versions
java
- Versions
- Java SE: 8u181, 11: Affected
- Java SE Embedded: 8u181: Affected
- JRockit: R28.3.19: Affected
No fix published
openjdk-8 Ubuntu:16.04:LTS
- Versions
- 8u66-b01-5
- 8u72-b05-1ubuntu1
- 8u72-b05-5
- 8u72-b05-6
- 8u72-b15-1
- 8u72-b15-2ubuntu1
- 8u72-b15-2ubuntu3
- 8u72-b15-3ubuntu1
- 8u77-b03-1ubuntu2
- 8u77-b03-3ubuntu1
- 8u77-b03-3ubuntu2
- 8u77-b03-3ubuntu3
- 8u91-b14-0ubuntu4~16.04.1
- 8u91-b14-3ubuntu1~16.04.1
- 8u111-b14-2ubuntu0.16.04.2
- 8u121-b13-0ubuntu1.16.04.2
- 8u131-b11-0ubuntu1.16.04.2
- 8u131-b11-2ubuntu1.16.04.2
- 8u131-b11-2ubuntu1.16.04.3
- 8u151-b12-0ubuntu0.16.04.2
- 8u162-b12-0ubuntu0.16.04.2
- 8u171-b11-0ubuntu0.16.04.1
- 8u181-b13-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 8u181-b13-1ubuntu0.16.04.1
Update to 8u181-b13-1ubuntu0.16.04.1
openjdk-8 Ubuntu:18.04:LTS
- Versions
- 8u144-b01-2
- 8u151-b12-1
- 8u162-b12-1
- 8u171-b11-0ubuntu0.18.04.1
- 8u181-b13-0ubuntu0.18.04.1
- 8u181-b13-1ubuntu0.18.04.1
- Affected ranges
- ECOSYSTEM: < 8u191-b12-0ubuntu0.18.04.1
Update to 8u191-b12-0ubuntu0.18.04.1
openjdk-lts Ubuntu:18.04:LTS
- Versions
- 9.0.4+12-2ubuntu4
- 9.0.4+12-4ubuntu1
- 10~46-4ubuntu1
- 10~46-5ubuntu1
- 10.0.1+10-1ubuntu2
- 10.0.1+10-3ubuntu1
- 10.0.2+13-1ubuntu0.18.04.1
- 10.0.2+13-1ubuntu0.18.04.2
- Affected ranges
- ECOSYSTEM: < 10.0.2+13-1ubuntu0.18.04.3
Update to 10.0.2+13-1ubuntu0.18.04.3
Original sources
- https://security.netapp.com/advisory/ntap-20181018-0001/
- https://access.redhat.com/errata/RHSA-2018:2942
- https://access.redhat.com/errata/RHSA-2018:3534
- https://access.redhat.com/errata/RHSA-2018:3003
- http://www.securityfocus.com/bid/105622
- https://usn.ubuntu.com/3804-1/
- https://access.redhat.com/errata/RHSA-2018:3002
- https://access.redhat.com/errata/RHSA-2018:3852
- https://www.debian.org/security/2018/dsa-4326
- https://access.redhat.com/errata/RHSA-2018:2943
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- https://access.redhat.com/errata/RHSA-2018:3533
- http://www.securitytracker.com/id/1041889
- https://access.redhat.com/errata/RHSA-2018:3521
- https://security.gentoo.org/glsa/201908-10
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03952en_us
- https://nvd.nist.gov/vuln/detail/CVE-2018-3183