CVE-2018-5135
CVE-2018-5135
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WebExtensions can bypass normal restrictions in some circumstances and use "browser.tabs.executeScript" to inject scripts into contexts where this should not be allowed, such as pages from other WebExtensions or unprivileged "about:" pages. This vulnerability affects Firefox < 59.
CVSS 7.5 · High · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
firefox
- Versions
- ≥ unspecified, < 59: Affected (custom)
Update to 59
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- 45.0+build2-0ubuntu0.14.04.1
- 45.0.1+build1-0ubuntu0.14.04.2
- 45.0.2+build1-0ubuntu0.14.04.1
- 46.0+build5-0ubuntu0.14.04.2
- 46.0.1+build1-0ubuntu0.14.04.3
- 47.0+build3-0ubuntu0.14.04.1
- 48.0+build2-0ubuntu0.14.04.1
- 49.0+build4-0ubuntu0.14.04.1
- 49.0.2+build2-0ubuntu0.14.04.1
- 50.0+build2-0ubuntu0.14.04.2
- 50.0.2+build1-0ubuntu0.14.04.1
- 50.1.0+build2-0ubuntu0.14.04.1
- 51.0.1+build2-0ubuntu0.14.04.1
- 51.0.1+build2-0ubuntu0.14.04.2
- 52.0+build2-0ubuntu0.14.04.1
- 52.0.1+build2-0ubuntu0.14.04.1
- 52.0.2+build1-0ubuntu0.14.04.1
- 53.0+build6-0ubuntu0.14.04.1
- 53.0.2+build1-0ubuntu0.14.04.2
- 53.0.3+build1-0ubuntu0.14.04.2
- 54.0+build3-0ubuntu0.14.04.1
- 55.0.1+build2-0ubuntu0.14.04.2
- 55.0.2+build1-0ubuntu0.14.04.1
- 56.0+build6-0ubuntu0.14.04.1
- 56.0+build6-0ubuntu0.14.04.2
- 57.0+build4-0ubuntu0.14.04.4
- 57.0+build4-0ubuntu0.14.04.5
- 57.0.1+build2-0ubuntu0.14.04.1
- 57.0.3+build1-0ubuntu0.14.04.1
- 57.0.4+build1-0ubuntu0.14.04.1
- 58.0+build6-0ubuntu0.14.04.1
- 58.0.1+build1-0ubuntu0.14.04.1
- 58.0.2+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 59.0+build5-0ubuntu0.14.04.1
Update to 59.0+build5-0ubuntu0.14.04.1
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- 46.0+build5-0ubuntu0.16.04.2
- 46.0.1+build1-0ubuntu0.16.04.2
- 47.0+build3-0ubuntu0.16.04.1
- 48.0+build2-0ubuntu0.16.04.1
- 49.0+build4-0ubuntu0.16.04.1
- 49.0.2+build2-0ubuntu0.16.04.2
- 50.0+build2-0ubuntu0.16.04.2
- 50.0.2+build1-0ubuntu0.16.04.1
- 50.1.0+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.2
- 52.0+build2-0ubuntu0.16.04.1
- 52.0.1+build2-0ubuntu0.16.04.1
- 52.0.2+build1-0ubuntu0.16.04.1
- 53.0+build6-0ubuntu0.16.04.1
- 53.0.2+build1-0ubuntu0.16.04.2
- 53.0.3+build1-0ubuntu0.16.04.2
- 54.0+build3-0ubuntu0.16.04.1
- 55.0.1+build2-0ubuntu0.16.04.2
- 55.0.2+build1-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.2
- 57.0+build4-0ubuntu0.16.04.5
- 57.0+build4-0ubuntu0.16.04.6
- 57.0.1+build2-0ubuntu0.16.04.1
- 57.0.3+build1-0ubuntu0.16.04.1
- 57.0.4+build1-0ubuntu0.16.04.1
- 58.0+build6-0ubuntu0.16.04.1
- 58.0.1+build1-0ubuntu0.16.04.1
- 58.0.2+build1-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 59.0+build5-0ubuntu0.16.04.1
Update to 59.0+build5-0ubuntu0.16.04.1
firefox Ubuntu:18.04:LTS
- Versions
- 56.0+build6-0ubuntu1
- 57.0.1+build2-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 59.0.1+build1-0ubuntu1
Update to 59.0.1+build1-0ubuntu1