CVE-2018-5158
CVE-2018-5158
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.
CVSS 8.8 · High · EPSS 10.2% · Fix available
- Published
- Updated
Affected products and versions
firefox esr
- Versions
- ≥ unspecified, < 52.8: Affected (custom)
Update to 52.8
firefox
- Versions
- ≥ unspecified, < 60: Affected (custom)
Update to 60
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 52.8.0esr-1
Update to 52.8.0esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 52.8.0esr-1
Update to 52.8.0esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 52.8.0esr-1
Update to 52.8.0esr-1
pdfjs-dist npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.0.550
Update to 2.0.550
pdfjs-dist npm
- Affected ranges
- SEMVER: < 1.10.100
Update to 1.10.100
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- 45.0+build2-0ubuntu0.14.04.1
- 45.0.1+build1-0ubuntu0.14.04.2
- 45.0.2+build1-0ubuntu0.14.04.1
- 46.0+build5-0ubuntu0.14.04.2
- 46.0.1+build1-0ubuntu0.14.04.3
- 47.0+build3-0ubuntu0.14.04.1
- 48.0+build2-0ubuntu0.14.04.1
- 49.0+build4-0ubuntu0.14.04.1
- 49.0.2+build2-0ubuntu0.14.04.1
- 50.0+build2-0ubuntu0.14.04.2
- 50.0.2+build1-0ubuntu0.14.04.1
- 50.1.0+build2-0ubuntu0.14.04.1
- 51.0.1+build2-0ubuntu0.14.04.1
- 51.0.1+build2-0ubuntu0.14.04.2
- 52.0+build2-0ubuntu0.14.04.1
- 52.0.1+build2-0ubuntu0.14.04.1
- 52.0.2+build1-0ubuntu0.14.04.1
- 53.0+build6-0ubuntu0.14.04.1
- 53.0.2+build1-0ubuntu0.14.04.2
- 53.0.3+build1-0ubuntu0.14.04.2
- 54.0+build3-0ubuntu0.14.04.1
- 55.0.1+build2-0ubuntu0.14.04.2
- 55.0.2+build1-0ubuntu0.14.04.1
- 56.0+build6-0ubuntu0.14.04.1
- 56.0+build6-0ubuntu0.14.04.2
- 57.0+build4-0ubuntu0.14.04.4
- 57.0+build4-0ubuntu0.14.04.5
- 57.0.1+build2-0ubuntu0.14.04.1
- 57.0.3+build1-0ubuntu0.14.04.1
- 57.0.4+build1-0ubuntu0.14.04.1
- 58.0+build6-0ubuntu0.14.04.1
- 58.0.1+build1-0ubuntu0.14.04.1
- 58.0.2+build1-0ubuntu0.14.04.1
- 59.0+build5-0ubuntu0.14.04.1
- 59.0.1+build1-0ubuntu0.14.04.1
- 59.0.2+build1-0ubuntu0.14.04.1
- 59.0.2+build1-0ubuntu0.14.04.4
- Affected ranges
- ECOSYSTEM: < 60.0+build2-0ubuntu0.14.04.1
Update to 60.0+build2-0ubuntu0.14.04.1
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- 46.0+build5-0ubuntu0.16.04.2
- 46.0.1+build1-0ubuntu0.16.04.2
- 47.0+build3-0ubuntu0.16.04.1
- 48.0+build2-0ubuntu0.16.04.1
- 49.0+build4-0ubuntu0.16.04.1
- 49.0.2+build2-0ubuntu0.16.04.2
- 50.0+build2-0ubuntu0.16.04.2
- 50.0.2+build1-0ubuntu0.16.04.1
- 50.1.0+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.1
- 51.0.1+build2-0ubuntu0.16.04.2
- 52.0+build2-0ubuntu0.16.04.1
- 52.0.1+build2-0ubuntu0.16.04.1
- 52.0.2+build1-0ubuntu0.16.04.1
- 53.0+build6-0ubuntu0.16.04.1
- 53.0.2+build1-0ubuntu0.16.04.2
- 53.0.3+build1-0ubuntu0.16.04.2
- 54.0+build3-0ubuntu0.16.04.1
- 55.0.1+build2-0ubuntu0.16.04.2
- 55.0.2+build1-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.1
- 56.0+build6-0ubuntu0.16.04.2
- 57.0+build4-0ubuntu0.16.04.5
- 57.0+build4-0ubuntu0.16.04.6
- 57.0.1+build2-0ubuntu0.16.04.1
- 57.0.3+build1-0ubuntu0.16.04.1
- 57.0.4+build1-0ubuntu0.16.04.1
- 58.0+build6-0ubuntu0.16.04.1
- 58.0.1+build1-0ubuntu0.16.04.1
- 58.0.2+build1-0ubuntu0.16.04.1
- 59.0+build5-0ubuntu0.16.04.1
- 59.0.1+build1-0ubuntu0.16.04.1
- 59.0.2+build1-0ubuntu0.16.04.1
- 59.0.2+build1-0ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 60.0+build2-0ubuntu0.16.04.1
Update to 60.0+build2-0ubuntu0.16.04.1
firefox Ubuntu:18.04:LTS
- Versions
- 56.0+build6-0ubuntu1
- 57.0.1+build2-0ubuntu1
- 59.0.1+build1-0ubuntu1
- 59.0.2+build1-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 60.0+build2-0ubuntu1
Update to 60.0+build2-0ubuntu1
Original sources
- https://access.redhat.com/errata/RHSA-2018:1415
- https://security.gentoo.org/glsa/201810-01
- https://access.redhat.com/errata/RHSA-2018:1414
- https://www.mozilla.org/security/advisories/mfsa2018-11/
- http://www.securitytracker.com/id/1040896
- https://www.debian.org/security/2018/dsa-4199
- https://usn.ubuntu.com/3645-1/
- https://lists.debian.org/debian-lts-announce/2018/05/msg00007.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1452075
- https://www.mozilla.org/security/advisories/mfsa2018-12/
- http://www.securityfocus.com/bid/104136
- https://nvd.nist.gov/vuln/detail/CVE-2018-5158